Part III

कर्मनियाङ्गी विषय / COMPUTER SCIENCE
( Vocational Component under General Stream )
( குழு பகுதி பொறியியல் வகும் / Tamil & English Versions )

Time Allowed : 3 Hours |
Maximum Marks : 150

Instruction : Check the question paper for fairness of printing. If there is any lack of fairness, inform the Hall Supervisor immediately.

Note :
1. Candidates should answer all the questions in PART - I (Objective type) (1 to 75) in the separate OMR Answer Sheet supplied. (Refer instructions given in the OMR Answer Sheet).

2. The number of the sign ' - ' (dash) as found in the right-hand top corner of the Question Paper (i.e., (1) or (2) or (3) or (4) should be shaded in the OMR Answer Sheet using HB Pencil.

3. Time allotted for answering question numbers 1 to 75 is first 75 minutes.

4. Parts - II and III questions (76 to 110) should be answered in the main answer-book.
Choose the correct answer:

1. What is the correct sequence of steps to select a blank line in a StarWriter document?
   A) Home  B) End  C) Delete  D) Enter.

   Which key should be pressed to insert a blank line in a StarWriter document?
   A) Home  B) End  C) Delete  D) Enter.

2. What is the correct keyboard shortcut to select the entire document in StarWriter?
   A) Ctrl + A  B) Ctrl + B  C) Ctrl + C  D) Ctrl + S.

In StarWriter, which keyboard shortcut is used to select the entire document?
   A) Ctrl + A  B) Ctrl + B  C) Ctrl + C  D) Ctrl + S.

3. Character
   A) Edit → Character  B) Format → Character  C) View → Character  D) Tools → Character.

   The command used to open character dialog box is
   A) Edit → Character  B) Format → Character  C) View → Character  D) Tools → Character.

4. What is the correct size of a font in StarWriter?
   A) points  B) inches  C) centimeters  D) lines.
5. Which key is used to get the spell check dialog box for spelling correction in the StarWriter document?

A) F1  B) F5  C) F7  D) F10.

6. In StarWriter, while correcting the spelling mistakes, the button clicked to skip all occurrences of the word is

A) Ignore  B) Ignore all  C) Change  D) Change all.

7. The key pressed to move forward through the cells of the table in StarOffice Writer is

A) Tab  B) Shift + Tab  C) Ctrl + Tab  D) Ctrl + Shift + Tab.

8. In StarOffice Writer, which of the following dialog boxes appears when Table → Table properties command is used?

A) Table property  B) Table properties  C) Table format  D) Table wizard.

9. In StarOffice Writer, the area at the bottom of the page is

A) portrait  B) landscape  C) header  D) footer.
10. Which one of the following spreadsheet packages was developed by Sun Microsystems?
A) Visicalc  
B) Excel  
C) Improve  
D) StarOffice Calc.

11. What is text operator in StarOffice Calc?
A) +  
B) !  
C) &  
D) %

12. In StarCalc, how cells A1, B1, C1, D1, E1 & F1 can be referred to as range in a worksheet?
A) A1 : F1  
B) A1 ; F1  
C) A1 ? F1  
D) A1 ; F1

13. In StarCalc, the symbol used to change the cell address into absolute cell address is
A) !  
B) $  
C) &  
D) ;

14. In StarOffice Calc, the command used to generate a series is
A) Sum  
B) Format  
C) Edit  
D) Fill
15. The command to change the width of a column in StarOffice Calc is:
A) Format → Row → Width  B) Format → Column → Width
C) Format → Width → Row  D) Format → Width → Column.

In StarOffice Calc, the command used to change the width of the column is:
A) Format → Row → Width  B) Format → Column → Width
C) Format → Width → Row  D) Format → Width → Column.

16. The command to change the width of a column in StarOffice Calc is:
A) Insert Chart  B) Insert Applet
C) Insert Formula  D) Insert OLE Object.

In StarCalc, the icon used to insert objects from other applications into a worksheet is:
A) Insert Chart  B) Insert Applet
C) Insert Formula  D) Insert OLE Object.

17. In computers, the value assigned to a variable is called:
A) Key  B) Information
C) Data  D) Report.

18. What is the equivalent of "file" in StarOffice Base?
A) பொன்  B) துரு
C) பொன்  D) துரு பொன்

In StarOffice Base, each row in a table represents:
A) File  B) Record
C) Field  D) Database.

19. A key that uniquely identifies a record in a database table is:
A) a data  B) a field
C) a record  D) a primary key.
20. கெளும் முக்கியம் கொலையால் அல்லது செய்யப்படாமல் செய்யப்படும் என்னைச் செய்யும்?
   A) கெட்டு செய்யம்
   B) கெட்டு ஆராய்ச்சி
   C) கெட்டு குறுக்கு
   D) கெட்டு மறுக்க
   A collection of related table is what in StarOffice Base?
   A) A form
   B) A report
   C) A database
   D) A record.

21. கெளும் முக்கியம் கொலையால் அல்லது செய்யப்படாமல் செய்யப்படும் என்னைச் செய்யும்?
   A) File → Save
   B) File → Tools → Save
   C) Edit → Save
   D) Edit → Fill → Save.
   The command used to save the database table is
   A) File → Save
   B) File → Tools → Save
   C) Edit → Save
   D) Edit → Fill → Save.

22. கெளும் முக்கியம் கொலையால் அல்லது செய்யப்படாமல் என்னைச் செய்யும்?
   A) 1
   B) 2
   C) 3
   D) 4.
   How many types of filters are used in StarOffice Base?
   A) 1
   B) 2
   C) 3
   D) 4.

23. கெளும் முக்கியம் கொலையால் அல்லது செய்யப்படாமல் என்னைச் செய்யும்?
   A) 15
   B) 13
   C) 20
   D) 18.
   How many number of field types are there in StarOffice Base?
   A) 15
   B) 13
   C) 20
   D) 18.

24. கெளும் முக்கியம், மக்களின் செயல்படுத்தலை மறைவு கருத்துறுத்துவதற்கு முன் கருத்துறுத்துவதற்கு முன் கருத்துறுத்துவதற்கு
   A) குறைவு
   B) மிச்சல்
   C) குறைவு
   D) குறைவு
   In StarOffice Base, a printed information that is assembled by gathering data based on user supplied criteria is called
   A) report
   B) query
   C) table
   D) form.
25. Toolbar elements from the examples in the text document into a presentation.
A) File → Send → Auto Abstract to presentation
B) File → Copy → Auto Abstract to presentation
C) File → Edit → Auto Abstract to presentation
D) Edit → Send → Auto Abstract to presentation.

The command used to transfer each heading together with its accompanying paragraphs in the text document into a presentation is:
A) File → Send → Auto Abstract to presentation
B) File → Copy → Auto Abstract to presentation
C) File → Edit → Auto Abstract to presentation
D) Edit → Send → Auto Abstract to presentation.

26. GIF format is limited to a palette of
A) 5 colors
B) 6 colors
C) 7 colors
D) 8 colors

27. in multimedia, the pattern of the sound that you hear is
A) Analog wave
B) Digital wave
C) Hybrid wave
D) Frequency.

28. The technique of distorting a single image to represent something else is
A) Morphing
B) Warping
C) Sampling
D) Modelling.

29. AIFF audio filename extensions
A) .avi
B) .aiff
C) .aud
D) .wav

Files in the AIFF format have the extension
A) .avi
B) .aiff
C) .aud
D) .wav
30. Shockwave என்றும் 2.0 என்றும் புதுமை
A) IBM
B) Microsoft
C) Macromedia
D) Apple.

The shockwave format was developed by
A) IBM
B) Microsoft
C) Macromedia
D) Apple.

31. StarOffice Impress அல்லது Shift + Ctrl + N கூட்டுப் புதுமையிலும் தற்கொலை செய்ய உண்டாய 2.0 வரும் நபர் என்னும் நேரானது?
A) Academic presentation
B) Templates
C) Documents
D) Templates and Documents.

Which dialog box appears when Shift + Ctrl + N buttons are clicked from StarOffice Impress?
A) Academic presentation
B) Templates
C) Documents
D) Templates and Documents.

32. ஒரு ஸ்டீஸ் நூற்றணவைகளில் செய்யப்பட்டுள்ள வலுவற்றை வேறு வகையான வலுவற்றை செய்யப்பட்டுள்ள வலுவற்றை வருகைக்கு வேறு வகையான வலுவற்றை வருகைக்கு?
A) Show logo
B) Effect
C) Automatic
D) Default.

Which option allows you to manually control the transition of slides using options such as mouse click?
A) Show logo
B) Effect
C) Automatic
D) Default.

33. ஒரு முக்கிய மற்றும் பிரிவைகளில் குறிப்பிட்டுள்ள ஆய்வுக்கு கீரைக்கு நூற்றரேங்கு
A) F1
B) F5
C) F6
D) F11.

In StarOffice Impress, the key pressed to start slide show is
A) F1
B) F5
C) F6
D) F11.

34. முக்கிய விளக்கங்களிலிருந்து வணங்கு, வண தள வேளாண்மை முறைமை
A) Hide → Slide
B) Slide show → Hide
C) Slide show → Show / Hide slide
D) Slide show → Hide slide.

The command used to hide the slide(s) in the slide show is
A) Hide → Slide
B) Slide show → Hide
C) Slide show → Show / Hide slide
D) Slide show → Hide slide.
35. Which key combination is used to print the slides in StarOffice Impress?
A) Ctrl + A  B) Ctrl + P
C) Alt + Ctrl + P  D) Ctrl + Alt + P.

36. Which among the following makes it easy to represent real systems in software programs?
A) Object  B) Control statements
C) Computer  D) Data hiding.

37. Which is template for entities that have common behaviour?
A) Class  B) Object
C) Variables  D) Attributes.

38. Which of the following is an escape sequence for new line / line feed?
A) \n  B) \n
C) \t  D) \b

Turn over
39. What is the value in \( c \) when the following snippet is executed?

```c
int a, b, c;

a = 8;
b = 3;
c = a/b;
c = ++c;
cout << c;
```

A) 1  
B) 2
C) 3  
D) 4

40. Which of the following is not a storage specifier?

A) auto  
B) static
C) register  
D) switch

41. Which qualifier specifies that the value of a variable will not change during the run time of a program?

A) size of  
B) static
C) unsigned  
D) const
42. How many methods are available for assigning data to the variables in C++?
A) 1  
B) 2
C) 3  
D) 4.

43. Which one of the following is the insertion operator or put to operator in C++?
A) <  
B) <<
C) >  
D) >>

44. Which is an assignment operator in C++?
A) +  
B) =
C) -  
D) ==

45. What is the output of the following snippet?
```cpp
int b = 10 > 20;
if(b)
    cout << "True Block";
else
    cout << "Else Block";
```
A) Else Block  
B) True Block
C) True Block Else Block  
D) Else Block True Block.

What is the output of the following snippet?
```cpp
int b = 10 > 20;
if(b)
    cout << "True Block";
else
    cout << "Else Block";
```
A) Else Block  
B) True Block
C) True Block Else Block  
D) Else Block True Block.
46. Which of the following is a multiple branching statement in C++?
A) if  B) while
C) switch  D) for:

47. What is the source code in computers' machine-readable form of a program called?
A) source code  B) object file
C) compiler  D) executable file.

48. Which of the following is a reference type only as
A) constants  B) variables
C) expressions  D) value.

49. Which of the following is a scope resolution operator?
A) main  B) friend
C) void  D) static.

50. Which of the following is called as scope resolution operator?
A) :  B) :
C) ::  D) ::
51. The array subscript always commences from
A) 0  B) 1  
C) 2  D) -1. 

52. Which one of the following functions returns the number of characters stored in the array?
A) strlen()  B) strmp() 
C) strcat()  D) strlen().

53. How many methods are available to display the contents of string in C++?
A) 1  B) 2  
C) 3  D) 4.

54. The most important feature of C++ is
A) state  B) behaviour  
C) method  D) class.

55. In C++, the functions are also called as
A) variables  B) classes  
C) methods  D) arrays.
56. If a visibility level is not mentioned then by default the class members will be treated as
A) Private  B) Public  
C) Protected  D) General.

57. Instruments allowing only selected access of components to objects and to members of other classes are called
A) inheritance  B) constructors 
C) data abstraction  D) encapsulation.

58. Class product

```c
int code, quantity;
float price;
```

```c
void main()
{
    product p1;
}
```

The number of memory allotted for the object p1 is
A) 2 bytes  B) 4 bytes 
C) 6 bytes  D) 8 bytes.
59. Which member variable is initialized only once, when the first object of its class is created?
A) static  B) private  C) public  D) protected.

60. In C++, polymorphism can be achieved through:
A) inheritance  B) data hiding  C) overloading  D) data abstraction.

61. During the integral promotion, a double data type can be converted into:
A) float or integer  B) float or void  C) integer or char  D) float or char.

62. Which of the following operators can be overloaded in C++?
A) ++  B) :  C) .  D) ?;

63. In C++, which functions return nothing?
A) inline functions  B) friend functions  C) overloaded functions  D) constructor and destructor.
64. Which of the following is default constructor?
   A) add()
   B) add(int s1)
   C) add(int s1, int s2)
   D) add(add & a).

65. Which of the following must have the same name as that of the class name?
   A) variable
   B) string literal
   C) constructor
   D) constant.

66. When the control reaches the end of class scope, which function is executed automatically?
   A) constructor
   B) destructor
   C) default constructor
   D) copy constructor.

67. Classes used only for deriving other classes are called
   A) base class
   B) derived class
   C) abstract class
   D) constructor.
68. The base class member which is not inherited in derived classes is
A) general  B) public
C) protected  D) private.

69. A class is derived from a class which is a derived class itself, then this is referred to as
A) multiple inheritance  B) multilevel inheritance
C) single inheritance  D) double inheritance.

70. Which enables data storage and management?
A) Archive unit  B) Data hiding
C) Data abstraction  D) Digitization.

71. Which enables online education programs leading to degrees and certifications?
A) e-shopping  B) e-learning
C) e-banking  D) e-governance.

| Turn over |
72. A category of IT enabled services pertaining to collection, digitization and processing of data coming from various sources is
   A) Data Management       B) Tele-medicine
   C) Data Digitization      D) Website Services.

73. How many steps are involved in medical transcription?
   A) 1          B) 2
   C) 3          D) 4

74. The set of rules for determining moral standards or what is considered as socially acceptable behaviour is called
   A) Leisure       B) Computer Crime
   C) Cracking      D) Ethics.

75. Making and using duplicate hardware and software is called
   A) virus          B) ethics
   C) piracy         D) cracking.
Answer any twenty questions in one or two sentences each: 20 x 2 = 40

76. வார்த்தையானது என்ன என்னை?

What is word processing?

77. StarOffice Writerில் வைத்தியும் வேதம் என்ன என்னை?

How will you delete the entire table in StarOffice Writer?

78. செல்ல வார்த்தையானது என்ன என்னை?

What is an electronic spreadsheet?

79. StarOffice Calc போன்றவை என்பது என்ன என்னை?

In StarOffice Calc, what are functions? Give an example.

80. மேம்படும் அவர்த்து பிள்ளா / (SQL) சான்றொழியை என்னை?

What is a Structured Query Language (SQL)?

81. StarOffice Base ல் போன்றவை என்பது என்னை?

What is a Form in StarOffice Base?

82. மூலம்பில்லா என்னை?

What is Multimedia?
83. What are the types of video compressions?

84. What is the use of notes view & normal view in presentation?

85. What is the use of master slide in presentation?

86. What is meant by polymorphism?

87. How are tokens classified?

88. Briefly write about conditional operator.

89. In C++, write down any 4 punctuators and their purposes.

90. What are control structures?

91. What are the advantages of functions in C++?
92. What is an Array? What are its types?

93. \[ \text{int } X \equiv \{ 0, 1, 2, 3, 4, 5 \}; \text{ then } X[1][1] \] to what value will it be set?

If \[ \text{int } X \equiv \{ 0, 1, 2, 3, 4, 5 \} \], then what is the value of \[ X[1][1] \]?

94. Define class.

95. How many access specifiers are there in a class body? What are they?

96. What is an operator overloading?

97. What are the functions of a constructor?

98. Define accessibility.

99. What is the use of ATM?

100. What is a virus?
Answer any seven of the following questions:

101. Explain the steps involved in searching and replacing a given word in a text document.

102. What are the various functions of the icons in the table formatting toolbar?

103. What are the advantages of using electronic spreadsheets?

104. Explain the method of inserting objects into a worksheet.

105. Explain the ways of manipulation of a database in StarOffice Base.

106. Write the syntax of for loop and explain it with an example.

107. Explain the call by value method in function with suitable example.

108. Write down the rules for function overloading.
Debug the following C++ program:

class add
{
    int s=0;
    protected:
    int n1, n2;
    public:
    add();
    {
        n1-n2=0;
    }
    accept()
    {
        cin>>n1>>n2;  
    }
    plus()
    {
        s=n1+n2;
    }
};

class add:privately subtract
{
    subtract;
    subtract();
    {
        sub=0
    minus()
    {
        add::acc();
        sub=n1-n2;
        cout<<sub;
    }
    void main[]
    {
        obj subtract;
        obj::minus();
    }
Write the output for the following C++ program:

```cpp
#include<iostream.h>
#include<conio.h>
void fun(char a, int times)
{
    for(int i=1; i<=times; i++)
        cout<<a;
    cout<<'\n';
}
void fun(int times=5, char a='*')
{
    for(int i=1; i<=times; i++)
        cout<<a;
    cout<<'\n';
}
void main()
{
    fun(3,'*');
    fun();
}
```